Update on Email Sender Display Issue

Informational

Update on Email Sender Display Issue

Status: closed
Date:
End:
Duration: 10 hours 15 minutes
Affected Components:
United States (us.agileresearch.medallia.com) Europe (eu.agileresearch.medallia.com) Email Queue Email Queue
Update

We identified and resolved an issue affecting the sender (“From”) email address used in a subset of Agile Research invitation emails. This issue was present from March 15, 2026 at 11:45pm PST to March 16, 2026 at 10:00am PST.



Resolved

We identified and resolved an issue affecting the sender (“From”) email address used in a subset of Agile Research invitation emails. This issue was present from March 15, 2026 at 11:45pm PST to March 16, 2026 at 10:00am PST.


During the generation of invitation emails, a logic issue in the email processing workflow caused some messages to be sent with an incorrect sender address associated with another Medallia customer domain.


Importantly:

  • The email content, recipient list, and survey links were not impacted

  • Messages were delivered only to the intended recipients

  • No cross-customer data was accessed or exposed

  • The issue has been fully mitigated 


At this time, no immediate action is required on your end. We are continuing to review the scope of impact and will follow up if any customer-specific next steps are identified.


We apologize for any confusion this may have caused and appreciate your partnership.