Email Notifications Delayed

Incident

Email Notifications Delayed

Status: closed
Start:
End:
Duration: 1 hour 28 minutes
Affected Components:
Canada (ca.agileresearch.medallia.com) Email Queue Survey Notifications
Update

The Agile Research email delivery service is currently experiencing a delay in the delivery of notifications. Our Production Services & Engineering teams are actively working to resolve this issue as soon as possible.

We know delivering emails quickly is important and hope to have services fully restored shortly.

Update

The issue causing the Agile Research email delivery service delay has been resolved. Our Production Services & Engineering teams are monitoring the system to ensure continued stability.

Resolved

The Agile Research email delivery service is no longer experiencing a delay in the delivery of notifications. Our Production Services & Engineering teams have restored service and verified that the issue has been resolved.